3.5
LowCVSS 3.1 · from CISA
CVE-2024-3586
LetterPress < 2.4.0 - Admin+ Stored XSS
LetterPress · Cross-site scripting · CWE-79AffectedLetterPress
FixUpdate to 2.4.0 or newer
PublishedOct 29, 06:00 · WPScan
Scored3.5 · CISA
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:04 UTC
What we know
No known exploitation. CISA KEV, checked 22:04 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, high privileges.
Someone has to open, click or run something first. CVSS: user interaction required.
Description
The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
From WPScan
Affected and fixed versions
ProductAffectedFixed inLetterPressbefore 2.4.02.4.0
Exploit code
Exploit-DBnone knownMetasploitnone knownNucleinone known