6.8
MediumCVSS 3.1 · from VulnCheck
CVE-2026-119424
OPNsense before 26.7.8 Wireless WPA Configuration Line Injection via Identity
core · CWE-93 · CWE-93Affectedcore
FixUpdate to 26.7.8 or newer
PublishedOct 30, 11:30 · VulnCheck
ScoredOct 30 · 6.8 · VulnCheck
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:09 UTC
What we know
No known exploitation. CISA KEV, checked 22:09 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, low privileges.
It only works under certain conditions, which makes it harder to pull off. CVSS: high attack complexity.
A successful attack can change data and take the service down. CVSS impact.
Description
OPNsense core before 26.7.8 contains a configuration line injection vulnerability that allows authenticated users with wireless-edit privilege to inject directives by embedding CR/LF characters in WPA fields. Attackers can place newlines in wpa.identity, wpa.passphrase, or RADIUS shared secrets to append arbitrary wpa_supplicant or hostapd directives loaded by root-run daemons.
From VulnCheck
Affected and fixed versions
ProductAffectedFixed incorebefore 26.7.826.7.8
Exploit code
Exploit-DBnone knownMetasploitnone knownNucleinone known