6.4
MediumCVSS 3.1 · from Wordfence
CVE-2026-6640
Media Library Assistant <= 3.35 - Authenticated (Contributor+) Stored Cross-Site Scripting via mla_link_attributes Parameter
Media Library Assistant · Cross-site scripting · CWE-79AffectedMedia Library Assistant
FixNo fix listed yet.
PublishedSep 11, 07:39 · Wordfence
ScoredSep 11 · 6.4 · Wordfence
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:08 UTC
What we know
No known exploitation. CISA KEV, checked 22:08 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, low privileges.
Description
The Media Library Assistant plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'mla_link_attributes' parameter in all versions up to, and including, 3.35 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
From Wordfence
Affected and fixed versions
ProductAffectedFixed inMedia Library Assistantup to 3.35–
Exploit code
Exploit-DBnone knownMetasploitnone knownNucleinone known