6.5
MediumCVSS 3.1 · from Patchstack
CVE-2025-22815
WordPress Button Block plugin <= 1.1.9 - Cross Site Scripting (XSS) vulnerability
button-block · Cross-site scripting · CWE-79Affectedbutton-block
FixUpdate to 1.2.0 or newer
PublishedJan 9, 2025, 15:39 · Patchstack
ScoredJan 9, 2025 · 6.5 · Patchstack
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:07 UTC
What we know
No known exploitation. CISA KEV, checked 22:07 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, low privileges.
Someone has to open, click or run something first. CVSS: user interaction required.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Button Block button-block allows Stored XSS.This issue affects Button Block: from n/a through <= 1.1.9.
From Patchstack
Affected and fixed versions
ProductAffectedFixed inbutton-blockearlier versions1.2.0
Exploit code
Exploit-DBnone knownMetasploitnone knownNucleinone known