4.3
MediumCVSS 3.1 · from Patchstack
CVE-2025-54694
WordPress Button Block Plugin plugin <= 1.2.0 - Cross Site Request Forgery (CSRF) Vulnerability
button-block · Cross-site request forgery · CWE-352Affectedbutton-block
FixUpdate to 1.2.1 or newer
PublishedAug 14, 2025, 10:34 · Patchstack
ScoredAug 14, 2025 · 4.3 · Patchstack
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:07 UTC
What we know
No known exploitation. CISA KEV, checked 22:07 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker only needs network access to the target. No login needed. CVSS: network, no privileges.
Someone has to open, click or run something first. CVSS: user interaction required.
Description
Cross-Site Request Forgery (CSRF) vulnerability in bPlugins Button Block button-block allows Cross Site Request Forgery.This issue affects Button Block: from n/a through <= 1.2.0.
From Patchstack
Affected and fixed versions
ProductAffectedFixed inbutton-blockearlier versions1.2.1
Exploit code
Exploit-DBnone knownMetasploitnone knownNucleinone known