CVEsvllm-projectCVE-2026-115916Published Oct 26, 17:18 · Updated Oct 26, 17:18 UTC
6.5
MediumCVSS 3.1 · from GitHub_M
CVE-2026-115916

vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device-side assert (engine crash / DoS)

vllm · CWE-129 · CWE-129
Affectedvllm
FixNo fix listed yet.
PublishedOct 26, 17:18 · GitHub_M
ScoredOct 26 · 6.5 · GitHub_M
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:11 UTC

What we know

No known exploitation. CISA KEV, checked 22:11 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, low privileges.
A successful attack can take the service down. CVSS impact.

Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, vllm/tokenizers/hf.py computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized prompt ID equal to the vocabulary size to pass validation. For a tensor-parallel size of one and an exact multiple-of-64 vocabulary, VocabParallelEmbedding.forward does not mask that value before F.embedding uses it, causing a CUDA device-side assertion and terminating the engine. This issue is fixed in version 0.32.0.

From GitHub_M

Affected and fixed versions

ProductAffectedFixed invllm< 0.32.0–

Exploit code

Exploit-DBnone knownMetasploitnone knownNucleinone known

References

github.com/vllm-project/vllm/security/advisories/GHSA-q97c-p368-75c4 · github.comrefsource_CONFIRMgithub.com/vllm-project/vllm/pull/59491 · github.comrefsource_MISCgithub.com/vllm-project/vllm/commit/37cecc8141e2dcba9dd534897a164d4baaf27229 · github.comrefsource_MISCgithub.com/vllm-project/vllm/releases/tag/v0.32.0 · github.comrefsource_MISC

Other CVEs in vllm

All 120 →
6.5vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs · CVE-2026-115918Oct 263.4vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server · CVE-2026-115917Oct 268.1vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE · CVE-2026-115915Oct 26