3.4
LowCVSS 3.1 · from GitHub_M
CVE-2026-115917
vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
vllm · CWE-942 · CWE-942Affectedvllm
FixNo fix listed yet.
PublishedOct 26, 17:20 · GitHub_M
ScoredOct 26 · 3.4 · GitHub_M
Exploit code publicNone known · checked 22:18 UTC
ExploitedNone known · CISA KEV checked 22:30 UTC
What we know
No known exploitation. CISA KEV, checked 22:30 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 22:18 UTC.
An attacker only needs network access to the target. No login needed. CVSS: network, no privileges.
It only works under certain conditions, which makes it harder to pull off. CVSS: high attack complexity.
Someone has to open, click or run something first. CVSS: user interaction required.
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
From GitHub_M
Affected and fixed versions
ProductAffectedFixed invllm< 0.32.0–
Exploit code
Exploit-DBnone knownMetasploitnone knownNucleinone known