CVEsvllm-projectCVE-2026-115918Published Oct 26, 17:21 · Updated Oct 30, 14:22 UTC
6.5
MediumCVSS 3.1 · from GitHub_M
CVE-2026-115918

vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs

vllm · Uncontrolled resource use · CWE-400
Affectedvllm
FixNo fix listed yet.
PublishedOct 26, 17:21 · GitHub_M
ScoredOct 26 · 6.5 · GitHub_M
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:11 UTC

What we know

No known exploitation. CISA KEV, checked 22:11 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, low privileges.
A successful attack can take the service down. CVSS impact.

Description

vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.

From GitHub_M

Affected and fixed versions

ProductAffectedFixed invllm>= 0.16.0, < 0.32.0–

Exploit code

Exploit-DBnone knownMetasploitnone knownNucleinone known

References

github.com/vllm-project/vllm/security/advisories/GHSA-x567-49g5-p4cf · github.comrefsource_CONFIRMgithub.com/vllm-project/vllm/pull/50300 · github.comrefsource_MISCgithub.com/vllm-project/vllm/commit/cff08b461e086523cee8bba5bd3c66d302625134 · github.comrefsource_MISCgithub.com/vllm-project/vllm/releases/tag/v0.32.0 · github.comrefsource_MISC

Other CVEs in vllm

All 120 →
3.4vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server · CVE-2026-115917Oct 266.5vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device-side assert (engine crash / DoS) · CVE-2026-115916Oct 268.1vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE · CVE-2026-115915Oct 26