CVEsDavid LingrenCVE-2026-118095Published Oct 29, 14:29 · Updated Oct 29, 16:49 UTC
6.5
MediumCVSS 3.1 · from Patchstack
CVE-2026-118095

WordPress Media LIbrary Assistant plugin <= 3.42 - Cross Site Scripting (XSS) vulnerability

media-library-assistant · Cross-site scripting · CWE-79
Affectedmedia-library-assistant
FixUpdate to 3.43 or newer
PublishedOct 29, 14:29 · Patchstack
ScoredOct 29 · 6.5 · Patchstack
Exploit code publicNone known · checked 21:18 UTC
ExploitedNone known · CISA KEV checked 22:10 UTC

What we know

No known exploitation. CISA KEV, checked 22:10 UTC.
No public exploit code known. Exploit-DB, Metasploit, Nuclei, checked 21:18 UTC.
An attacker needs network access and an account. CVSS: network, low privileges.
Someone has to open, click or run something first. CVSS: user interaction required.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows DOM-Based XSS.This issue affects Media LIbrary Assistant: from n/a through 3.42.

From Patchstack

Affected and fixed versions

ProductAffectedFixed inmedia-library-assistantearlier versions3.43

Exploit code

Exploit-DBnone knownMetasploitnone knownNucleinone known

References

patchstack.com/database/wordpress/plugin/media-library-assistant/vulnerability/wordpress-media-library-assistant-plugin-3-42-cross-site-scripting-xss-vulnerability?_s_id=cve · patchstack.comvdb entry

Other CVEs in media-library-assistant

All 21 →
6.5WordPress Media LIbrary Assistant plugin <= 3.42 - Sensitive Data Exposure vulnerability · CVE-2026-115594Oct 268.5WordPress Media LIbrary Assistant plugin <= 3.42 - SQL Injection vulnerability · CVE-2026-115948Oct 264.3WordPress Media LIbrary Assistant plugin <= 3.42 - Cross Site Request Forgery (CSRF) vulnerability · CVE-2026-97295Oct 26